为什么要升级GCC
因为一些程序的源码在make时,会提示GCC版本不够高(例如nodejs),而CentOS自带的版本是无法达到需求的,因此需要手动下载最新的GCC源码进行安装

首先安装CentOS7自带的GCC

yum install gcc gcc-c++

安装解压缩包bzip2

yum install bzip2

下载GCC5.4源码包并解压

cd /usr/local/src
wget https://ftp.gnu.org/gnu/gcc/gcc-5.4.0/gcc-5.4.0.tar.bz2
tar -jxvf gcc-5.4.0.tar.bz2

下载相关依赖组件
这个过程比较慢,其中会出现超时等提示,耐心等待就好

cd gcc-5.4.0
./contrib/download_prerequisites

建立一个文件夹存放编译的文件

mkdir gcc-build-5.4.0
cd gcc-build-5.4.0
/usr/local/src/gcc-5.4.0/configure --enable-checking=release --enable-languages=c,c++ --disable-multilib  

编译并安装

make -j 4

这个过程比较久,根据机器配置,1小时以上

make install

对引用进行处理
安装后执行命令

gcc -v

会发现版本并不是5.4.0,此时还需要对引用做处理

cd /usr/bin/
mv gcc gcc_back
mv g++ g++_back
ln -s /usr/local/bin/gcc gcc
ln -s /usr/local/bin/g++ g++

此时再使用查看版本命令,显示的应该就是5.4.0

 gcc -v
最后修改:2021 年 06 月 01 日 11 : 28 AM
感谢您的,打赏!